BrowZine System Requirements (iOS, Android & Web)

BrowZine for iOS

As of version 2.0.x, BrowZine requires iOS 11 or newer to run on iPads, iPhones and iPod Touches. If your device runs this iOS version or can be upgraded to do so then it will run BrowZine!

Devices using older versions of iOS may be able to run older versions of the BrowZine app, but we would recommend using a device capable of running the latest version for the best possible experience.


BrowZine for Android

As of version 2.0.x, BrowZine requires Android 5 (Lollipop) or newer to run.

Will BrowZine for Android run on my device if it supports this operating system requirement?  

Most likely! While we do our best to test on a variety of devices, it is impossible to test on the literally thousands of different devices available worldwide. Third Iron tests on some of the most popular devices including:
  • Google Nexus
  • Samsung Galaxy Tab and Note
  • Amazon Kindle Fire HD
My Android device has a slot for an SD card which I use to expand the capacity of my device.  Does BrowZine take advantage of this?

Yes!  While BrowZine uses internal device storage for the app and some cache to help the app run smoothly, if you use the "Save Article" feature in BrowZine, this is automatically saved to your external SD card so that you don't fill up your precious internal memory on your device.  While most PDFs are fairly small, if you have hundreds of them saved, this can really start to make a difference so utilizing this external storage can be very helpful!  Of course, if you do not have this feature or an SD card installed, BrowZine will save to your internal memory instead.

BrowZine Web and LibKey


Browzine.com and LibKey utilize the latest in web technologies to deliver a fast, modern experience. As such, the latest browsers are necessary to deliver this experience to users. BrowZine is tested and works well on:

Google Chrome (Version 43+)
Safari (Version 8+)
Mozilla Firefox (Version 31+)
Microsoft Internet Explorer (Version 11+)
Microsoft Edge (Version 16+)

If you encounter any issues using these versions or newer, please let us know. 

Feedback and Knowledge Base